Problemas com feed no WordPress 2.5.1

Depois que eu atualizei o WordPress do Lugares e Viagens, o feed de repente parou de funcionar. Existem algumas pessoas reportando este problema no Fórum do WordPress mas o que resolveu mesmo o meu problema eu encontrei no Zen and the art of progamming.

Aparentemente para corrigir o erro basta alterar a forma como o feed é chamado. Por exemplo, eu costumava chamar o feed assim: http://exemplo.com/?f agora chamo assim http://exemplo.com/?feed=atom, só isso foi suficiente. Se você chama o feed direto no head do site ou se passa ele por dentro do Feedburner, de qualquer maneira terá que corrigir para o novo caminho.

Não sei exatamente o que aconteceu neste último upgrade, sabemos apenas que a solução acima corrigiu o problema. Se alguém souber algo novo, é só dar um grito aqui nos comentários.

Valeu Paulo Itapirema por ter me avisado.

  • http://www.clubeletras.net/blog/ Sergio Grigoletto

    Aconteceu o mesmo problema comigo. Apenas mudei o sufixo.

    Onde estava:
    http://www.clubeletras.net/blog/feed/rss/

    Mudei para:
    http://www.clubeletras.net/blog/feed/rss2/

    Quem passou essa dica foi o Cardoso. Comigo, deu certo.

  • Paulo Itapirema

    Valeu, Henrique,

    sempre é bom poder ajudar!

  • http://www.turbocar.com.br/ Felipe Mafra

    Funcionou também para o problema que eu tinha no feed dos comentários do meu blog. Antes estava assim:

    (…)wpcommentsrss2.php e mudei para

    (…)?feed=rss2

    e funcionou.

    Valeu! :)

  • Alice Désir&e

    Ai, o WordPress é muito chato. Já tive um blog lá mas cansei de ser tudo muito difícil de negociar e mudei pro blog que estou hoje, que aliás comecei ontem!

    Bjs!!

    =1

  • Anderson Cust&oacute

    Sempre usei "andersoncustodio.net/feed" e nunca tive problema.

  • Gustavo Ribeiro

    não tive esse problema com a atualização do WP.

    não sei se por estar chamando o feed de outra forma (a default dele) ou se já ter atualizado com a correção.

    abs

  • http://justplay.info Rafael R

    Salvou-me, vi que não tava atualizando no blogblogs, entrei no feed e ele tava estacionado. Agora tudo ok! Thanks! :)

  • http://ww35.credouai.com/ Fillipe

    Amigos, estou com problemas no RSS.

    Não consigo de forma alguma salvá-lo no FeedBurner.

    Está me dizendo que é um erro no Wassup Plugin, mas não faz sentido para mim!

    O link do rss seria http://www.credouai.com/feed/rss2/

    Alguem saberia me ajudar?

    Obrigado e abs!

  • Alan Nogueira

    Muito Bom, me ajudou, vlw!