Mozilla Firefox 1.5 Release

Minhas primeiras impressões são as melhores possíveis. As principais alterações no novo Mozilla Firefox foram torná-lo mais rápido na navegação, o que pode ser notado facilmente; implementação do que eles chamam de FastBack, que te permite voltar a uma página já visitada instantaneamente, sem refresh ou delay, update automático, função de drag and drop nas abas, suporte a CSS3 e outras coisas mais.

O browser realmente está mais rápido como prometeram e a publicidade da imprensa e o apoio do Google com certeza deve incomodar e muito o Internet Explorer que só tem tido baixas no último ano. Algumas gafes como a chamada para os desenvolvedores corrigirem os hacks, ou seja, fazer o serviço que eles não fizeram, o boato ou notícia de que os bugs de CSS não serão corrigidos completamente, o que vai manter o Firefox como o melhor browser a adotar os padrões e a queda para 85% da fatia do mercado, considerando os 95% anos atrás, tem deixado a Microsoft de cabelo em pé.

Algumas extensões utilizadas na versão anterior não vão funcionar perfeitamente, mas no geral a maioria já possui atualizações. Na instalação ele te dá a opção de atualizar automaticamente todas as extensões que já estão instaladas na versão anterior. A extensão LiveLines não vai funcionar e até esta manhã, o próprio Mozilla não conseguiu fazer o update automaticamente. Mas já tem alguém que deu um jeito nisso e disponibilizou uma versão do LiveLines que funcione.

[UPDATE]

Stuart Colville do Muffin Research Labs encontrou uma solução interessante para as extensões que não funcionam na nova versão 1.5

  1. Faça o Download da extensão, ao invés de instalar diretamente
  2. Renomeie o arquivo .xpi para .zip
  3. Abra o arquivo .zip e edite o arquivo install.rdf (clique com o botão direito e edite com o NOTEPAD por exemplo)
  4. Altere a variável maxVersion para 1.6
  5. Renomeia novamente o arquivo, agora de .zip para .xpi
  6. Instale a extensão, clicando em File -> Open File CTRL+O

O Flávio Japs encontrou esta solução e fez os testes e realmente funciona.

[/UPDATE]

  • Flávio Theruo

    É isso aí Henrique, a nova versão do Firefox está excelente.

    Muito mais rápida, tanto na inicialização quanto na renderização das páginas.

    Com certeza a galera da Micro$oft deve estar de cabelo em pé. Hehehehehehehehe…

    Também escrevi umas coisinhas da nova versão do Firefox.
    http://www.japs.etc.br/2005/11/firefox-15-primeir

  • Felipe Diesel

    Uma coisa que sinto falta no Firefox é ele salvar as imagens de background q estão no css.

    Acho q nenhum browser faz isso…

  • http://janio.sarmento.org Janio

    Pena que o Adblock endoidou, agora não posso mais acessar o Banco do Brasil com ele no novo FF.. :-( E algumas extensões importantes, como o GreaseMonkey, vão fazer falta. Por isso, até que a máquina do trabalho esteja 100%, não vou atualizar meu Firefox de casa. ;)

  • Nelson

    Para falar a verdade os browsers que melhor implementão os padrões web são: konqueror, safari (os unicos dois com versão estavel a passarem completamente no acid2), e logo depois o firefox, mas precisam se cuidar pois o opera 9 (ainda em alfa) ja passou no acid2 tambem, mas como esta em alfa ainda não conta, mesmo assim ainda uso firefox :D

  • Jeff

    A versão 1.5 em português pode estar com bug. Não consigo instalar extensões mesmo aquelas que se dizem prontas para essa versão. Reparei também que foi mudada a frase que bloqueava ou permitia a instalação das extensões nas versões anteriores do Firefox, acessada por "–>Ferramentas –>Opções". Antes dizia: "Permitir a instalação de programas", ou algo assim.. agora diz: "Alertar se sites tentarem instalar extensões ou temas". Acho curioso isso, então isso significa que sempre é permitido, só se deve alertar ou não? Por via das dúvidas inseri o endereço dos addons do Mozilla e tais nas permissões mas mesmo assim não funcionou de jeito nenhum.

  • Jeff

    Só complementando, o que acontece ao instalar uma extensão é uma mensagem que diz: "A instalação do software está desabilitada. Clique em "Editar opções" para habilitar e tente novamente". Só que não funciona. Fiz testes com várias extensões, todas dizendo que o limite da versão é Firefox 1.6 alguma coisa. E nada. Desinstalei a versão em português e instalei a versão em inglês. Mesmo problema. Fiz então os passos indicados acima com uma extensão específica, aliás, tinha duas linhas com aquela variável, fiz a modificação na primeira, não funcionou, então fiz com a segunda linha onde aparece a variável, não funcionou. Já sei o que vou fazer, vou casar, talvez dê mais certo.

  • Jeff

    O que seria de nós se não fosse o Google, não? Encontrei a solução, é REALMENTE um bug do Firefox 1.5 que acontece em certos casos. Em resumo, ao instalar a nova versão 1.5 tendo outra previamente instalada, ele traz uma informação da anterior que poderia causar esse bug (não é para todos). Para ajudá-los a não passar por essa experiência que quase me fez decidir casar, risos…, é muito simples: digite about:config no Firefox e resete a variável "xpinstall.enabled". Funcionou perfeitamente.

  • Jeff

    Opa, estava esquecendo do link que fala do bug:

  • Luis

    O ff é rápido e eficiente, mas… não consigo acessar o internet Bank do Bradesco, após inserir a chave de segurança do bradesco… da pau!

    Socket Error

    Host name lookup for 'wwwss.bradesco.com.brhttps' failed

  • http://revolucao.etc.br/ Henrique Costa Perei

    Pois é, eu também tenho este problema na Credicard. Por isso eu não desinstalo o Internet Explorer. Mas lembre-se, quando um site dá pau no Mozilla, o problema está no caboco que fez o site e não no Mozilla.

  • Luis

    Sim, "webstandards" e uma palavra que nem todos os webdesigners, e desenvolvedores conhecem.

  • Luis

    O atributo "alt" no ff funciona?

    No meu ff não funciona!

  • MAICON MAX

    ALGUEM PODERIA ME ENSINAR COMO INSTALAR O GREASEMONKEY, POIS TENHO A VERSAO FF 1.5.0.1 E QNDO CLICO NO LINK INSTALL GREASEMONKEY, ABRI UM POPUP DIZENDO Q A INSTALAÇAO DE PROGRAMAS ESTA DESATIVADA. COMO FAÇO, JA TENTEI ACHAR UMA OPÇAO PARA LIBERAR A INSTALAÇAO MAIS NAO TIVE SUCESSO..

    ME AJUDEM POR FAVOR !!!! ATE JA REINSTALEI O FF MAIS NAO ADIANOTOU NADA !!

    AGRADESÇO DESDE JA,

    MAICON

  • Roni

    O atributo alt da tag não funciona. Alguém sabe o que é? NO IE aparece.